SAP Knowledge Base Article - Public

3649353 - Eligible user does not have enrollment created with auto enrollment job

Symptom

An user which should be eligible for a benefit is considered ineligible in the auto enrollment job response

Environment

  • SAP SuccessFactors HCM Suite 
  • SAP SuccessFactors Employee Central - Global Benefits

Reproducing the Issue

  1. Run the auto-enrollment job for a user eligible for a benefit
  2. Verify the benefit overview for the user the benefit does not appear
  3. Check the execution log in the Execution Manager Dashboard and it indicates the user is not eligible.
  4. Review the eligibility rule for the benefit; it uses context-current user, which may cause execution issues

Cause

The eligibility rule for the benefit is configured using context.current user, which can lead to issues during job execution.

Resolution

We need to configured the rule directly referencing the entity, such as job information, instead of context-current user.

Also, the recommendation is to make sure the eligibility rule is configured with the specific scenario for each benefit type. All the specific scenarios are outlined in the guide

Whenever configuring business rules we can use a rule trace to check its execution. More details about how to configure it can be checked in the article 2257064.

    See Also

    Guide: Determine Eligibility for Insurance Plan Benefit

    Guide: Evaluate Eligibility Based on Benefit Master Data Change Job Configuration

    Keywords

    auto-enrollment, eligibility rule, context-current user, benefit overview, sap successfactors employee central, global benefits, execution log, rule trace, evaluate job, insurance plan benefit, create or update Benefit Enrollments for Benefit Master Data Changes, GBF, SF, benfit , KBA , LOD-SF-EC-GBF , Global Benefits , Problem

    Product

    SAP SuccessFactors Employee Central all versions