Symptom
Customer has Inferred Skills in Talent Intelligence Hub.
After running the Update Inferred Skills to Confirmed Job, the Skills remained inferred in TIH, thought the job appears to have completed Successfully.
Environment
SAP SuccessFactors Talent Intelligence Hub
Reproducing the Issue
- Scheduled Job Manager
- Execute "Update Inferred Skills to Confirmed"
- Job appears to complete successfully.
- under View Details > message states "Skipping RCM and JPB inferred skills as TIH Skill Extractor job is not completed successfully."
Next,
- Check "Skill Extractor Job" in Scheduled Job Manager
- If the job has status "Failed" > View Details
- Error message is similar to the following: "Error occurred. com.successfactors.sca.ServiceApplicationException"......"Please Re-trigger the upgrade from upgrade center."
Lastly,
- Confirm if under the Upgrade Center > view recently completed upgrades, if the Upgrade "AI-Assisted Skills Architecture Creation" has Failed, this needs to be corrected first.
Cause
Skill Extractor Job has failed, due to the AI-Assisted Skills Architecture Creation upgrade failure.
Resolution
Currently under investigation by engineering.
If the above error is experienced, please log a case with support, including:
- Support Access
- Confirmation on which if any of the above jobs have failed
- From Import and Export Data, download and attach the "SkillExtractionRerunStatusEntity" and "SkillExtractionStateEntity", or ensure the support user has access to this tool.
See Also
Keywords
skill extraction, AI-assisted skills, inferred skills, Update Inferred Skills to Confirmed , KBA , LOD-SF-TIH-SKL , AI Assisted Skills , Problem
SAP Knowledge Base Article - Public