Symptom
Creating a Business Rule to Trigger an Email Notification When the Personal Data Collection Step is Completed
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Configure custom notification template & relative business rule
- Initiate onboarding for candidate
- Go to Admin Center > Email Services > Email Status
- The notification is not triggered
Cause
Custom MDF objects in email triggers via business rule
Resolution
- The custom MDF (Metadata Framework) objects are not supported for use in email triggers configured via business rule.
- Currently, only standard MDF objects, such as Process or other pre-delivered objects, are supported for triggering email notifications through business rules.
- If a custom MDF object is used, the email trigger will not function as expected.
- This is a known platform limitation and is in line with the current system design.
- For more details, please refer to the following guide: Creating Business Rule to Trigger Email Notification – SAP Help Portal
See Also
Keywords
Business Rule, Trigger, Email Notification, Personal Data Collection Step, Completed, onboarding, , KBA , LOD-SF-OBX-EML , Notifications , Problem
Product
SAP SuccessFactors Onboarding 2511
SAP Knowledge Base Article - Public