SAP Knowledge Base Article - Public

3649799 - Business Rule Message Not Triggered Due to Event Reason NULL – Employee Central

Symptom

    When executing a business rule created to raise a message, the rule does not display the expected message because the Event Reason is retrieved as NULL.
    In the rule trace, the following appears:

    Retrieved 'jobInfo_event_reason.value'. Value: 'null'.
    The expression 'jobInfoModel.jobInfo_event_reason.value.event' is considered to be NULL, as the property 'value' of 'jobInfo_event_reason' is found to be NULL at 'jobInfoModel.jobInfo_event_reason.value'.

    Environment

    SAP SuccessFactors Employee Central

    Reproducing the Issue

    1. Go to: Employee Profile
    2. Navigate to 'Actions' and select 'Change Job and Compensation Info'.
    3. Check Job Information.
    4. Make the needed changes
    5. Expected outcome: A message should pop up.
    6. Actual outcome: No message is displayed.

    Cause

    The business rule to raise the message was created with the Basic scenario. Because of this, it is executed before the Event Reason Derivation rule. As a result, the Event Reason is still NULL when the rule runs.

    Resolution

    Update the business rule scenario to 'Validate HRIS Elements'.
    With this configuration, the rule will be triggered after the Event Reason Derivation business rule, ensuring the Event Reason is retrieved correctly and the message is raised as expected.

    See Also

    Keywords

    Event Reason Derivation, Rule, Order, Basic, Raise Message, onSave, Validate, Scenario, NULL, Event Reason , KBA , LOD-SF-EC-JOB-RUL , Job Info Business Rules , Problem

    Product

    SAP SuccessFactors Employee Central all versions