SAP Knowledge Base Article - Public

3649814 - error "unable to perform content operation for user" when opening ui screen in ui designer

Symptom

  • UI screen cannot be opened in the UI designer.
  • Error message displayed: "Unable to perform content Operation for user KC123XXABC in Client XXX".

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Cloud Applications Studio

Reproducing the Issue

  1. Open the affected UI Component in the UI designer.
  2. Observe the error message: "Unable to perform content Operation for user KC123XXABC in Client XXX".

Cause

  • When creating a Custom Action CT (Change Transaction), a Stable Anchor is generated.
  • A subsequent CT can reuse the same Stable Anchor.
  • If the original CT is deleted, the Stable Anchor associated with it is also deleted.
  • This deletion causes the error: "ButtonGroupAnchor missing in the UXView" during the merge process which in turn raises error in the UI designer- Unable to perform content Operation for user KC123XXABC in Client XXX

Resolution

There are two options here to resolve

  • Revert the deletion of the original CT that created the Stable Anchor.

OR

  • Delete the subsequent CT that reused the Stable Anchor.

Since access is not possible on partner side, please raise a case

  1. quoting this KBA,
  2. choosing the desired option 
  3. providing permission to carry out the action on support side

Keywords

ui designer, unable to perform content operation, error message, stable anchor, custom action ct, button group anchor, merge process, ui screen, change transaction, deletion , KBA , AP-RC-UIF-RT , UI Framework Runtime , Problem

Product

SAP Cloud Applications Studio all versions

Attachments

KBA.png