Symptom
- Users in SAP Analytics Cloud (SAC) are able to delete comments authored by other users.
- They are able to delete critical information or historical discussions, either unintentionally or deliberately.
Environment
- Planning
- SAP Analytics Cloud (SAC)
Cause
- The issue arises from the current configuration of access permissions in SAP Analytics Cloud, which allows users to delete comments made by others.
Resolution
Regarding the access permission types available in the Share Story dialog (After choosing the user or team that will receive access to the story) you can Choose:
- View: Users can only view the story but cannot make any changes.
- Edit: Users can open and modify the story, but they do not have full administrative rights.
- Full Access: Users have complete control, including editing, sharing, and Deleting.
- Custom Access: This option allows you to define specific rights for users (for example: the ability to edit, Delete Delete Comments...).
If you are using Custom Access, you can select access depending on which permission you want to grant or remove:
- View Comment: Users can view and like comments.
- Add Comment: Users can view and like comments, start new comment threads, and add comments to existing threads. They can also delete comment threads they started and their own comments. When this option is selected, the View Comment option is automatically selected as well.
- Delete Comment: Users can view and like comments and delete their own or others’ comments. When this option is selected, the View Comment option is automatically selected as well.
See Also
Keywords
sap analytics cloud, sac, comment permissions, delete comment, restrict comment deletion, collaborative planning, audit trail, compliance, transparency, user engagement, permissions configuration, sac guide , KBA , LOD-ANA-PL , Planning , How To
Product
SAP Analytics Cloud all versions
SAP Knowledge Base Article - Public