Symptom
- Instructors are not receiving cancellation notifications upon time slot deletion.
- Notifications are received only when the entire class is deleted.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Create a class with multiple time slots >
- Configure a primary instructor with a valid email >
- Delete one time slot from the class's Agenda tab >
- Observe that the notification is not received by the instructor >
- Inactivate and then delete the class >
- Observe that now the notification is received by the instructor.
Cause
One of the following prerequisites is not met:
- Under Global Application Settings:
- : Enabled.
- : Must be populated with an email address.
- : Enabled.
- Under the Class record:
- Ensure that there are users enrolled in the class.
- In the Details tab, under Email Confirmation for Admin-Initiated Actions, enable "Email confirmation to the Instructor".
Resolution
- Learning Administration >
- Make sure the prerequisites are met >
- Open the Class record >
- Open the Agenda tab >
- Delete one time slot >
- The instructor will receive a new System Enrollment Notification.
See Also
Keywords
time-slot deletion, instructor, cancellation email, class notifications, email settings, enrollment update, notification, Learning, timeslot, lms, time, slot, agenda, segment, so, schedule offering, systemenrollmentnotification , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS-SCH , Class - Scheduled Offerings , LOD-SF-LMS-INS , Instructors and My Classes , Problem
Product
SAP SuccessFactors Learning all versions
SAP Knowledge Base Article - Public