Symptom
The Ingestion API was working fine for some time but has stopped with no entry or message in the Source Data log.
Cause
Some probable causes encountered in the past:
- The old API endpoints were used
- Network Firewalls (e.g., Cisco ASA, Fortinet, Palo Alto) rules may have been introduced/updated to block outbound/inbound traffic based on IPs, ports, or protocols.
- Web Application Firewalls (WAF) (e.g., Cloudflare, AWS WAF, Imperva) rules may have been introduced/updated.
- Antivirus/Endpoint Protection (e.g., CrowdStrike, Symantec, Microsoft Defender for Endpoint) may have been introduced/updated
- EDR/XDR solutions (e.g., SentinelOne, Carbon Black) can block unauthorized processes or outbound connections
- Intrusion Detection/Prevention Systems (IDS/IPS) (e.g., Snort, Suricata, Cisco Firepower) may have been introduced/updated
- Secure Web Gateways (SWG) (e.g., Zscaler, Netskope, Cisco Umbrella) may have been introduced/updated to filter web traffic, including API requests over HTTP/S, based on policies
- Proxy Servers may have been introduced/updated
- DNS Filtering / DNS Firewalls or changes in Domain names
Resolution
Ensure that API endpoint used is correct. This can be found in the Connection entity in Process Intelligence. See: Connector - Ingestion API | SAP Help Portal
The resource responsible for network administration/policies can:
-
Check logs from proxy/firewall/security tools.
- Ensure the calling app or script is trusted and signed.
-
Test from a different network or VPN to confirm if it's network-level.
- Signavio Support can verify that the Ingestion API is operational and demonstrate over a call if required
Keywords
Ingestion, API, soe, SAP, Signavio, process, Intelligence, Blocked, No error , KBA , BPI-SIG-PI-INT , Integration / Schedules / SQL Filter / Delta criteria , Problem
SAP Knowledge Base Article - Public