SAP Knowledge Base Article - Public

3650702 - SAP Signavio Process Intelligence On-premises connection to Snowflake fails with No enum constant com.signavio.pi.etl.extractor.shared.services.AuthenticationType.KEYPAIR_AUTH

Symptom

When trying to create a Snowflake connection using the On-premises extractor, it fails with error:


checking credentials: rejected. Reason: {"message":"Exception caught, caused by: Testing connection failed for SNOWFLAKE with the following error message (No enum constant com.signavio.pi.etl.extractor.shared.services.AuthenticationType.KEYPAIR_AUTH): No enum constant com.signavio.pi.etl.extractor.shared.services.AuthenticationType.KEYPAIR_AUTH,caused by: Testing connection failed for SNOWFLAKE with the following error message (No enum constant com.signavio.pi.etl.extractor.shared.services.AuthenticationType.KEYPAIR_AUTH): No enum constant com.signavio.pi.etl.extractor.shared.services.AuthenticationType.KEYPAIR_AUTH","status":500,"error":"Internal server error","timestamp":... 

Cause

Signavio Process Intelligence started supporting KEYPAIR_AUTH type authentication for Snowflake from May 27, 2025

See: What's New in SAP Signavio Process Intelligence | SAP Help Portal 

The On-premises extractor version being used predates KEYPAIR_AUTH support. 

Resolution

Upgrade the On-premises package to the latest version so it includes support for KEYPAIR_AUTH authentication for Snowflake.

See: Updating the On-Premises Extractor Version (Linux and Windows) | SAP Help Portal 

Keywords

soe, On-prem, Extractor, Snowflake, On-premises, KEYPAIR_AUTH, AuthenticationType, enum, constant, 500, error , KBA , BPI-SIG-PI-DS , Data Source (CSV, Connector) , Known Error

Product

SAP Signavio Process Intelligence all versions