Symptom
Error occurs while attempting to complete the Personal Data Collection task in the Onboarding dashboard as an admin user even if no issue is found in the Process object:
[COE0019] The To-Do task couldn’t be fetched. Check for any errors that might have occurred during the creation of the To-Do task.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Log in as an admin user
- Navigate to the Onboarding dashboard and search for the candidate
- Click on "View Details" for the Personal Data Collection step
- Click on "Complete Task"
- See error: [COE0019] The To-Do task couldn’t be fetched. Check for any errors that might have occurred during the creation of the To-Do task.
Cause
Possibly caused by a server issue at the time of task creation.
Resolution
Kindly follow below steps to resolve the error:
- Navigate to "Update Process Flows for Onboarding and Offboarding" page > re-update the configuration
- Go to "OData API Metadata Refresh and Export" page > refresh the cache
- Go to Onboarding dashboard > search for the candidate > restart the onboarding process
- Test to open the task as admin user again
See Also
Keywords
SAP, SuccessFactors, Onboarding, onboarding dashboard, personal data collection, [COE0019], to-do task error, task completion error, onboarding process, admin user error, metadata refresh, process flow update, cache refresh , KBA , LOD-SF-OBX-PDC , Personal Data Collection , Problem
SAP Knowledge Base Article - Public