Symptom
In a workflow rule for installation point/registered product it is noticed that when changing a field ABC, it works but when changing field DEF, it does not work.
Environment
SAP Sales/Service Cloud
Reproducing the Issue
- Go to the Products work center.
- Go to the Registered Products view.
- Open registered product ABC (where ABC is the ID of a registered product).
- Click in edit button.
- Change field DEF (where DEF is a field of registered product).
- Workflow GHI does not trigger (where GHI is a workflow for installation point/registered product).
- Change field JKL.
- Workflow GHI triggers.
Cause
A Registered Product is a combination of two business objects - Installation Point and Individual Product. Any registered product will basically have an instance created in both business objects.
The workflow object that we see in SAP Sales/Service Cloud for Registered Products is created on the Installation Point business object.
Any changes hence done on the installation point will always trigger workflow rules. Any change done however on the Individual Product related data will not trigger the workflow rules.
Warranty Information for a registered product, for example, is stored on the Individual Product business object part. Hence these changes there never trigger workflow rules.
In example above, JKL is a field from Installation Point business object part (triggering workflows i.e. notes section) where GHI is a field from Individual Product business object part (not triggering workflows i.e. Warranty field).
Resolution
It is suggested to consider PDI implementation for achieving this requirement. If the feature/functionality is required urgently, please refer to KBA ##3475641 - Functionality Currently not Available (C4C)
See Also
Keywords
Workflow, For, Installation, Point, Registered, Product, Not, Working, Warranty, ID, WARRANTY_ASSIGNMENT|WARRANTY_KEY_PRODUCT_ID - Warranty ID, /Root/Items/ProductInternalID, /Root/Items/Description, Root-.PrimaryInstalledObject-.InstalledObjectIndividualProduct-.IndividualProduct-.ServiceProcessInformation-.ServiceProcessInformationWarrantyAssignment-~WarrantyKey-~ProductID-~content (InstallationPoint) /Root/ServiceProcessInformationWarrantyAssignment/WarrantyID, Root-.Description-~Description-~content (Warranty), Root-~ProductInternalID-~content (Warranty) , KBA , LOD-CRM-WKF , Workflow , LOD-LE-PRD-WTY , Warranty , Problem
SAP Knowledge Base Article - Public