Symptom
When updating a field, the values in other fields are unexpectedly removed or cleared.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Change the value of a specific field.
- Notice that the data in other fields is removed or cleared after the change.
Cause
This issue is typically caused by a business rule associated with the field that was changed.
The business rule may have been configured to set the values of other fields to null or empty when the specific field is updated, or there may be a misconfiguration within the business rule that has resulted in a null value.
Resolution
To address the issue, review and adjust the onChange business rule associated with the field.
- Navigate to 'Manage Rules in Recruiting'.
- Select the entity in question (Job Requisition / Offer Detail / Candidate / Job Application).
- If applicable, select the relevant template.
- Locate the business rule that is associated with the field causing the issue.
- Review the rule and identify any conditions or actions that set other field values to null or empty.
Tip: When reviewing complex rule expressions, it is recommended to create a rule trace using the Business Rule Execution Log tool. This can help better understand the rule behavior.
For further assistance, please contact SAP Support.
See Also
Keywords
RCM, Business Rule, onChange, Status, Change, Update, Edit, Fill in, Populate, Field, Data, Removed, Cleared, Disappear, Blank, Empty, Wiped out, Erased, null, Overwritten , KBA , LOD-SF-RCM-RUL , Recruiting Rule Issues with MDF Platform , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , LOD-SF-RCM-JOB , Job Postings & Requisitions , LOD-SF-RCM-APP , Applicants and Job Applications , Problem
SAP Knowledge Base Article - Public