SAP Knowledge Base Article - Public

3651820 - Email notifications not triggered for some payment batches - SAP S/4HANA Cloud Public Edition

Symptom

  • Some payment batches can trigger email notifications, while others cannot.
  • Approver didn't receive email notification for payment batch approval.

Environment

SAP S/4HANA Cloud Public Edition.

Reproducing the Issue

  1. Create a payment run which contains several payment batches in SAP S/4HANA Cloud Public Edition.
  2. Attempt to trigger an email notification for the payment batch approver.
  3. Observe that one of the batch triggered email notification while others not.

Cause

  • Several payment batches created out of single payment run.
  • The system only send email notification once for one of the payment batches in that single payment run.

Resolution

There are two options to resolve the issue:

  • Option 1:

            Separate the Payment Runs based on the accounts, then it will generate the e-mails correctly.

  • Option 2:

            Use flexible workflow, refer to attachment "Bank Communication Management with an Email.pdf" for detailed guidance.

See Also

Refer to KBA 3625714 for email notification for forwarded payment batch.

Keywords

Payment batch, email notification, approver email, SAP S/4HANA Cloud, workflow configuration, notification issue, payment batch approval, single document batch, direct bank communication, single payment run, several payment batches. , KBA , FIN-FSCM-BNK-2CL , Direct Bank Communication (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions

Attachments

Bank Communication Management with an Email.pdf