Symptom
- Custom priority defined with a blank priority key in SSCUI '102583 - Define Priorities for Each Priority Type' does not trigger automatic dates determination.
- No error message is displayed when saving a custom priority with a blank priority key.
- Users can manually enter dates as a workaround, but the system does not adjust dates automatically when the blank priority key is selected.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
Scenario 1:
- Open the "Change Maintenance Notification" app.
- Enter a notification number.
- Change the priority to custom priority with a blank priority key and observe that the dates are not adjusted automatically according to definition in SSCUI 102583.
Scenario 2:
- Open the "Create Maintenance Order" app.
- Enter required data for maintenance order, like order type, maintenance plan, technical object, etc.
- Select the priority to custom priority with a blank priority key and observe that the dates are not adjusted automatically according to definition in SSCUI 102583.
Cause
The system cannot recognize an empty priority key, even if priority text is provided and relative dates are defined in SSCUI 102583, as a result, date determination cannot be triggered.
Resolution
- Avoid using a blank priority key for custom priorities.
- Use supported keys, such as "A", "B", "C", or "D" when defining custom priorities.
- Refer to SAP Knowledge Base Article 2326112 for guidance on namespace restrictions in SSCUI '102583 - Define Priorities for Each Priority Type'.
See Also
Keywords
Custom priority, Blank priority key, Automatic date determination, Maintenance notification, Maintenance Order, SSCUI 102583, Define Priorities for Each Priority Type, Namespace restriction, Relative dates. , KBA , PM-CNT-2CL , S/4HANA Plant Maintenance Content (Public Cloud) , PM-FIO-2CL , Fiori User Interface (UI) for PM (Public Cloud) , Problem
Product
SAP S/4HANA Cloud Public Edition all versions
SAP Knowledge Base Article - Public