SAP Knowledge Base Article - Public

3652352 - Activity List ID Not Displaying in Task OWL Screen

Symptom

  • The "Activity List ID" field added to the Task OWL screen using Adaptation mode does not display any value, even though tasks created under the Activity List are visible.
  • The expected value for the "Activity List ID" field is blank.

Environment

SAP Cloud for Customer

Reproducing the Issue

Step1. Create an Activity List:

  1. Navigate to the Activity List view.
  2. Use the Quick Create screen to fill in details with type as 'Task List'.
  3. Save and open the Activity List.
  4. In the overview screen, click "New", then "Select Accounts", and select an account.
  5. A task is created based on the account.

Step 2. Add the "Activity List ID" field to the Task OWL screen:

  1. Navigate to the Task Work Centre view and open the Task OWL screen.
  2. Enable Adaptation Mode.
  3. Edit the OWL screen and add the existing "Activity List ID" field.
  4. End Adaptation.

Observe that the "Activity List ID" field remains blank and does not display the expected value.

Cause

  • The "Activity List ID" field is not available in the standard system for the Task OWL screen.
  • It only displays the Activity List Name. 

Resolution

  1. Confirm that the "Activity List" option is visible on the Task header using Adaptation mode.
  2. Note that the system behavior is as expected: the "Activity List ID" field is not designed to display in the Task OWL screen.
  3. If the feature or functionality is required urgently, refer to the SAP Knowledge Base Article:

See Also

Keywords

activity list id, task owl screen, sap cloud for customer, adaptation mode, blank field, activity list name, sap c4c, task work centre, sap cloud tenant, task list creation, sap activity list, sap task adaptation  , KBA , LOD-CRM-ACT , Activities , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions