Symptom
- In the CDS view I_BUSINESSPARTNER, the "changed at" field shows inconsistent time zones.
- For some suppliers, the time is displayed in UTC, while for others, it is displayed in JST.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Access the CDS view I_BUSINESSPARTNER.
- Observe the "changed at" field for different suppliers.
- Note that the time zones displayed are inconsistent, with some entries in UTC and others in JST.
Cause
Each object saves the change document in the database using a different timezone. The system time for a cloud system is set to UTC+0, but different applications can save the time based on either the 'System Time' or the 'User Time.'
The time that users see is set in the 'Maintain Business User' App for the CB user who made the change.
The Business Partner Apps operate on 'User Time,' and changes reflect the time of the user who made the change. This is the design from the Business Partner side.
Resolution
The system time for a cloud system will be set to UTC+0 but the different applications can save the time based on either the "System Time" or the "User Time".
The Business Partner Apps work on the "User Time" and the changes will reflect the time of the user who made the change, this is the design from the Business Partner side.
See Also
Keywords
cds view, i_businesspartner, changed at field, inconsistent time zones, utc, jst, user time, system time, maintain business user, sap s/4hana cloud, business partner apps, time zone discrepancy , KBA , AP-MD-BP-BP-2CL , Data (Public Cloud) , Problem
SAP Knowledge Base Article - Public