Symptom
- Boolean type extension fields created under the Case Service entity and exposed within specific case types are initially displayed with a "-" by default.
- Users must click the edit icon next to a dash symbol to interact with the fields.
Environment
- SAP Service Cloud Version 2
- SAP Sales Cloud Version 2
Reproducing the Issue
- Log in to SAP Service Cloud V2.
- Open a Case in the detailed view (e.g., Case 601).
- Navigate to the Troubleshooting phase in the Case Flow.
- Observe that the following Boolean fields are not displayed by default, and instead a "-" is shown.
Cause
- The Boolean fields are not explicitly set with a value (i.e., true or false).
- In SAP Service Cloud V2, the toggle UI element only appears when a value is present.
- If the field value is null, the system does not render the toggle button to avoid misleading users with an implied default state.
Resolution
- This is the expected system behavior.
- For a toggle button to appear, the Boolean field must be explicitly set to true or false.
- Displaying a toggle in a "switched off" state when the value is not defined could be misleading.
- If you would like this behavior to be changed, please submit your request via the SAP Customer Influence Program.
- For all roadmap features, please visit the SAP Service Cloud V2 Roadmap Explorer page.
- Please note that any forward-looking roadmap item is subject to change and timelines are tentative in nature.
- When it's available, the information will be shared via the What's New documentation with links.
Keywords
boolean fields, sap service cloud v2, extension fields, toggle button, case type, toggle functionality, case management, boolean extension fields, inconsistent display, troubleshooting phase, usability issue, default display, sap service cloud. , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , Problem
Product
SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public