Symptom
- User clicks Save or opens an Opportunity -> Attachments tab and expects a single action to download all attachments for that Opportunity.
- The UI only allows individual download of attachment files (or limited multi-download via Library in some tenants). No native "Download All" button is available.
Environment
SAP Cloud for Customer
Cause
This is product behavior in the standard C4C UI: there is no built-in function that downloads all attachments for Opportunities in one click.
Attachments are exposed by the platform and can be consumed via the C4C OData service (AttachmentFolder / AttachmentFolderDocuments / /$value). However, the product UI does not provide a bulk-export action.
Resolution
As it is a behavior of the system, raise an idea in the SAP Sales Cloud Portal requesting this functionality:
Influence Portal
The Customer Influence portal is the correct channel for requirements of changes in the system behavior.
There, other customers can also vote for the idea and depending on the demand from the customer community, the developers will evaluate and plan accordingly for a possible implementation of this new feature.
See Also
Keywords
C4C; SAP Cloud for Customer; Opportunity attachments; bulk download; mass extraction; OData; AttachmentFolder; AttachmentFolderDocuments; $value endpoint; Postman; Python script; data migration; Library Work Center; Customer Influence; enhancement request; pagination; throttling; communication user; binary download; zip export , KBA , LOD-CRM-INT-API , OData API (C4C Only) , Product Enhancement
SAP Knowledge Base Article - Public