SAP Knowledge Base Article - Public

3652694 - Elements not available for selection when creating a Custom CDS View but available in Customer Data Browser when visualizing the standard data source

Symptom

When opening a Standard CDS View in Customer Data Browser app, the result is displayed with the selected columns. When creating a Custom CDS View based on the same data source and searching for the columns names, the elements are not found.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Go to Custom CDS Views app
  2. Click on "Create"
  3. Select the datasource and create the view 
  4. In "Elements" tab, select to add elements and search for the column names 
  5. The fields are not available

Cause

In Custom CDS Views application, you need to search for the elements using their Technical Names. 

In Customer Data Browser application, when previewing the data, there's a button on the top right side of the page named "View Technical Names". Once you click in this button, you'll be able to see the technical names of the elements and this is the name that you need to search for in the Custom CDS Views application to add in your view. 

Resolution

Search for the technical names in the Custom CDS View. 

See Also

Keywords

CDS View, custom cds view, data source, elements, not available, not found, customer data browser , KBA , BC-SRV-APS-GKE , Generic CDS Key User Editor , Problem

Product

SAP S/4HANA Cloud Public Edition all versions