Symptom
Some users configured as explicit recipient builder in onboarding email are not receiving the notification emails.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to Email Service > Active Templates.
- Select a template.
- Click on the "Define Email Content" button.
- In the "To Recipient Builder" field, select "Explicit recipient builder".
- Add users and email addresses in the explicitRecipients part.
- Trigger the email.
- Observe that the user do not receive the email.
Cause
A mismatch in the email address configuration between the email template and the UDF caused the issue.
Resolution
- Verify the email addresses configured in the explicitRecipients part of the email template.
- Cross-check the email addresses with the corresponding UDF.
- Correct any mismatched email addresses in the email template.
- Test the email notification to confirm resolution.
Keywords
explicit recipient builder, onboarding notification, email delivery issue, sap successfactors onboarding, email template, explicitRecipients, notification settings, email mismatch, UDF, explicit recipient, explicit email address , KBA , LOD-SF-OBX-EML , Notifications , Problem
Product
SAP SuccessFactors Onboarding all versions
SAP Knowledge Base Article - Public