SAP Knowledge Base Article - Public

3653151 - Curriculum with retraining has no Expiration Date

Symptom

A user completed a curriculum that has retraining. However, when checking the curriculum's status, the Expiration Date says "N/A".

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Log into HCM > navigate to Learning Administration > Learning Activities > Curricula >
  2. Search for the required curriculum or create a new one >
  3. At the curriculum's record > Content tab > add items as needed and configure them as required, making sure there are retraining settings >
  4. Assign the curriculum to the users >
  5. The users complete the initial assignment >
  6. However, when the users access the Curriculum Status page, the 'Expiration Date' says "N/A" >
  7. The same is also observed when Learning Admins check the user's record at Learning Administration > People > Users > user's record > Curricula tab.

Cause

This happens when the curriculum's contents are configured with an Effective Date in the future.

The Effective Date is the start date when the system will include the item as part of curriculum completion. Before reaching that future date, items with future Effective Date are not considered by the system against the overall curriculum status, including its Expiration Date.

Resolution

To have an Expiration Date displayed to the user and for administrators (at the user's record > Curricula tab), please define an Effective Date in the past.

More details on how to edit the curriculum settings (including Effective Date) can be found at KBA 2485268 - How to Setup Curriculum Retraining.

See Also

Keywords

sf, sfsf, lms, curriculum, expiration, date, basis, effective, retraining, initial, assignment, missing, populate, n/a, na, not, available , KBA , LOD-SF-LMS-CUR , Curricula , Problem

Product

SAP SuccessFactors Learning all versions