SAP Knowledge Base Article - Public

3653184 - Complete E-signature step not triggered, Scheduled status in Manage Data > Process - Onboarding

Symptom

  • Post completion of ADC step, "Complete E-signature step" did not trigger.
  • There is a BPE tile error: 
    Error creating document for user (user Id), ONBOARDING process (process Id)
    HCP Error Message: Http Status Code 500
    Operation /odata/PDF (for FormId XXXX Locale xx) returned status code 500

 Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Complete New Hire Data Review step / Personal data collection / Additional data collection step
  2. Complete E-signature step did not trigger
    Or
  3. Complete compliance task
  4. E-signature for Compliance form did not trigger

Cause

Cause 1: Document generation failed due to issues with the placeholder mapping.

Cause 2: Checkbox configuration is incorrect.

Cause 3: Compliance Form does not exists in the system

Resolution

Solution 1:

  1. Go to Manage Data → Create New → Document Template Mapping Preview. Give Document Template Mapping Preview ID as you wish, enter Onboardee’s Process ID, in Document Template enter affected template name (which was shown in BPE error).
  2. See which placeholder has unwanted characters such as spaces, tab spaces (\t), or special characters.
    Open affected form in Maintain Onboarding & Offboarding Templates and check for path of affecting placeholder.
  3. Go to Manage Data → Onboarding Data Collection User Configuration, then search with Onboardee Process ID, check for affected placeholder data.
  4. Please log in as Admin, edit the affected fields in the step, save the changes, and then restart the BPE error.

Solution 2:

  1. For checkboxes, you are required to pass a value which matches either the export value on the checkbox in adobe acrobat as seen below (this will show the checkbox as checked) or off (this will show the checkbox as unchecked).
  2. Any other value passed in the rule will throw an error in the BPE tile.
  3. You can use the document template mapping preview page to help validate which values were passed for each field on the document.

Solution 3:

  1. Compliance form was not migrated to NEO environment
  2. In Provisioning > Manage Scheduled Jobs > Run Compliance Metadata Sync job
  3. Restart the error from To Do > Business Process

If error persists:

  1. Admin Center > Check Tool > System Health
  2. Select Application as Onboarding
  3. Select the option Compliance templates for Print Forms service are consistent (CheckMissingComplianceTemplatesinPFS) 
  4. Run Check
  5. If issues identified click the Quick Fix button to resolve the inconsistency
  6. Restart the error from To Do > Business Process

Keywords

Onboarding, OBX, E-signature did not trigger, Signature step locked, Signature scheduled, signature did not trigger, Http response status code 500, Cannot find formTemplate with id, is not a valid option for the field, valid values are, HCP Error Message: Http Status Code 500 , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , Bug Filed

Product

SAP SuccessFactors Onboarding