SAP Knowledge Base Article - Public

3653222 - Incoming Ticket Messages from FSM Executed Out of Sequence

Symptom

TicketBulkReplicationIn web service messages from FSM to C4C are not always processed in the same the sequence in which they were created. 

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Goto Administrator -> General Settings -> Web Service Message Monitoring.
  2. Filter for Service Interface 'TicketBulkReplicationIn'
  3. For the messages in question, the message with the older 'Created On' value was processed later (as shown by the value of the field 'Executed On') than the other, more recently created message.

Cause

In-Application Sequencing can only be used with the complete transmission scenario.
Since FSM and C4C have different data model, enabling complete transmission is not possible and all messages coming from FSM (either via full sync or delta mode) must be processed. In the case of bulk message updates, object locks may occur (see kba 3097620) and in such cases it is impossible to guarantee the messages will be reprocessed in the correct sequence.

Resolution

This is a technical limitation and cannot be avoided.

 

 

See Also

https://me.sap.com/notes/2847405

Keywords

SenderSequenceNumberValue , KBA , LOD-CRM-SRP-CSI , Integration of service ticket with Core systems , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , AP-RC-WSM , Web Service Message Monitoring View , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem

Product

SAP Cloud for Customer core applications 2508