Symptom
- The behavior of SAML User Column at SuccessFactors SSO provisioning page, for IAS integration with SuccessFactors.
- IAS Activation, via SuccessFactors > Upgrade Center, fails despite attempts to reupload metadata and adjust configurations.
- The following error messages can be found:
- "The subject (___) in SAML response does not exist in BizX"
Environment
- SAP SuccessFactors HCM Suite
- SAP Cloud Identity Services – Identity Authentication IAS
- SAP Cloud Identity Services – Identity Provisioning IPS
Cause
In SuccessFactors provisioning, the "SAML User Column" field was used to define user authentication login name configurations when a corporate IdP was set directly at the SSO provisioning page.
However, with the deprecation of third-party IdP directly integrated with SuccessFactors (as per KBA 3523900), there is no need to use this field anymore.
Any user authentication configuration should be defined at IAS level, not in SF provisioning anymore. Due to that, if the customer tries to use the "SAML User Column" field, the IAS Activation process will fail and the users' authentication process won't succeed.
Resolution
The "SAML User Column" field in SF provisioning has been deprecated.
If you are still using this field, clear any data in it, and leave the "SAML User Column" field empty.
See Also
Keywords
IAS activation, SAML response error, certificate issue, provisioning settings, SAML User Column, login name, subject name identifier, IAS integration, SF authentication, corporate IDP, metadata reupload, activation failure. , KBA , LOD-SF-PLT-IAS , Identity Authentication Services (IAS) With BizX , Problem
SAP Knowledge Base Article - Public