SAP Knowledge Base Article - Public

3653809 - Reference field missing when creating a new custom field in SAP Sales/Service Cloud Version 2

Symptom

When attempting to create a new custom field and establish a relationship to an existing external field, the option to select the reference field usage is missing.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Navigate to the configuration area for custom fields in the SAP Sales/Service Cloud system.
  2. Attempt to create a new custom field.
  3. Try to establish a relationship to an existing external field by selecting the reference field usage.
  4. Observe that the option to select the reference field usage is not available.

Cause

The issue occurs because the customer did not select the Data Type and Data Format.

Resolution

Ensure that the Data Type and Data Format are selected first before attempting to search for the Custom Reference Attribute.

Keywords

reference field usage, custom field creation, missing reference option, sap sales cloud, sap service cloud, custom reference attribute, data type, data format, field relationship, configuration issue , KBA , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0

Attachments

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