Symptom
Custom fields are created in service contracts but they are not able to be added as columns in the item overview table the "Manage Service Contracts" app.
Environment
SAP S/4HANA Cloud Public Edition
Cause
The "Service Contract Item List" is not included in the personalization options for custom fields as per the current design of the app.
Resolution
To have custom fields available in the personalization options of the item overview table, raise a feature request through the Customer Influence Portal.
See Also
KBA 2963059 - How to Submit Feature Requests for SAP S/4HANA Cloud Product
Keywords
custom fields, service contracts, manage service contracts, item overview table, adopt UI, personalization options, extensibility, service contract item list. , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem
SAP Knowledge Base Article - Public