SAP Knowledge Base Article - Public

3654922 - Daily target hours not showing in app "Manage My Timesheet"

Symptom

  • Daily target hours are not displayed in the "Manage My Timesheet" application.
  • Instead of showing the expected format (e.g., 0:00/8:00), only the actual hours worked are visible.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Access the "Manage My Timesheet" application.
  2. Observe that the daily target hours are not displayed, and only actual hours worked are visible.

Cause

  • Missing availability data.

Resolution

  1. Ensure that availability data is updated for the employee. This can be checked via CDS View I_TimeOverviewByWrkAgrmtAndDte
  2. If the system is not integrated with SuccessFactors, update the availability data using the API_MANAGE_WF_AVAILABILITY.

See Also

_TimeOverviewByWrkAgrmtAndDte

API_MANAGE_WF_AVAILABILITY

Keywords

daily target hours, manage my timesheet, cross application timesheet, missing availability data, S/4HANA, target hours not displayed, new joiners, API_MANAGE_WF_AVAILABILITY, SuccessFactors integration, timesheet issue, availability data update , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , How To

Product

SAP S/4HANA Cloud Public Edition all versions