SAP Knowledge Base Article - Public

3654973 - Members of the Target Group Cannot be Contacted due to Error "E-mail Address Invalid" in Campaigns

Symptom

After executed the Direct E-Mail campaign, in the Execution Details, you find some members are not contacted due to the error "E-mail Address Invalid".

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Marketing work center.
  2. Go to the Campaigns view.
  3. Open the campaign ABC. (ABC represents the ID of the campaign).
  4. Go to Execution Details tab, there are some members not contacted.
  5. Select the query "Members Not Contacted", it shows the reason "E-mail Address Invalid'.

Cause

In the account master data, the indicator "E-Mail Invalid " is ticked. This means the E-Mail is marked as invalid for communication. To check the "E-Mail Invalid" indicator, follow the steps below.

  1. In the Execution Details tab of the campaign.
  2. Double click the Account Name listed in the "Members Not Contacted' list, system opens the account master data.
  3. Click View All, in the General tab, the indicator "" is located in Main Communication part. You can check the value there.

Resolution

It is the designed behavior.

If the indicator "

You can correct the e-mail address and remove the indicator manually in order to contact the business partner in future campaigns.

See Also

Help document: Create and Execute a Direct E-mail Campaign

Keywords

campaign; direct e-mail; Members Not Contacted; E-mail Address Invalid. , KBA , SRD-CRM-MKT , Marketing , Problem

Product

SAP Business ByDesign all versions