Symptom
- The automatic creation of Individual Customer is enabled at the channel level.
- The Case Type Determination from Business Rules is not defined.
- When an email is received from an unknown (non-V2 customer) email address, the system fails to create an Individual Customer.
- In Inbound Email Monitoring, these emails appear with a Party validation error stating: "Please enter a party with role Account".
- As a result, the Individual Customer and associated case is not created.
Environment
- SAP Service Cloud Version 2
- SAP Sales Cloud Version 2
Reproducing the Issue
- Send an email to the channel 'XYZ'.
- Navigate to Settings -> Case -> Case Auto Creation Monitoring.
- Observe that the event errors out with the 'Party validation error' message: "Please enter a party with role Account".
- Check under Individual Customer, and also noticed no new Individual Customer was created for this interaction.
Cause
- A Code List Restriction (CLR) is applied for the Individual Customer business entity.
- The restriction is tied to a custom role (e.g., XYZ), and during the Email-to-Case process, the system attempts to assign this role to the default party.
- Since the CLR prevents this action, the creation of the Individual Customer fails, leading to the error and case creation failure.
Resolution
- To resolve the issue, follow these steps:
- Navigate to Settings → Extensibility → Code List Restriction.
- Set Business Entity to Individual Customer.
- Review any role restrictions applied (e.g., CRM000). Then do one of the following:
- Option 1: Disable the role restriction entirely if it is not needed.
- Option 2: Modify the rule to prevent conflicts:
- For example, if the role is CRM000 and the record is created by the technical system user, ensure that the system assigns a valid, unrestricted role instead.
- Navigate to: Settings → Extensibility → Code List Restrictions
- Open the restriction named XXXX (e.g BP_ROLE)
- Set Business Entity to Individual Customer
- On the Configure Restrictions screen:
- Locate the Status Code = Active
- Enable the checkbox under the “Customer” column for this row . This allows the system to assign CRM000 with status ACTIVE to new Individual Customers.
- For example, if the role is CRM000 and the record is created by the technical system user, ensure that the system assigns a valid, unrestricted role instead.
- Tip: Always validate the changes by triggering the Email-to-Case process again and monitoring in Case Auto Creation Monitoring to ensure no errors are present.
See Also
- Configure Emails
- KBA 3433959 - Automatic case creation via Email channel is failing
- KBA 3634169 - Case Autocreation Failure: Please Enter a Party with Role Account
- KBA 3620824 - Case Creation Failure - "Please enter a party with role Contact of Account "
Keywords
email channel, sap service cloud version 2, individual customer creation, party validation error, please enter a party with role account, auto-create individual customer, bp_role code list restriction, email-to-case, default party, case auto creation monitoring, crm000 , KBA , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , CEC-CRM-CH , Chat for SAP Sales/Service Cloud , Problem
Product
SAP Service Cloud Version 2 all versions
SAP Knowledge Base Article - Public