Symptom
For specific countries, it is expected that the Contact Person specified on the XML file for the Customer Invoice ABC's output template is pulled from its preceding Sales Order XYZ. However, the Contact Person is different than the one maintained on the sales document.
(ABC represents the customer invoice's ID and XYZ represents the Sales Order's ID).
Environment
SAP Business ByDesign
Reproducing the Issue
- Navigate to the Customer Invoicing workcenter.
- Go to the Invoice Documents view.
- Search for the ID ABC.
- Click on Edit.
- Click on View All.
- Select the Preview button.
There is a person defined as the Contact for this document.
- In the same invoice, go to the Document Flow tab.
- Open the Sales Order XYZ.
- Go to the General tab.
Under the Contact section, the Contact name is not the same from the document ABC's preview.
Cause
The Contact Person specified on the invoice's XML file and consequently on the Output Form Template will always be the Account's Main Contact maintained at the time of the invoice release.
It will not be pulled from any preceding document.
Resolution
This is the expected system behavior.
In case the invoice is desired to have a different Contact Person, the Main Contact must be changed in the master data. Then, the invoice should be canceled and released again to ensure the updated contact is reflected in the XML.
See Also
KBA 3235080 - No Contact Person Name in XML Data of Customer Invoice
KBA 2780535 - Contacts Not Available in Customer Invoices
Keywords
customer invoice, contact person, xml file, main contact, output settings, form template, preceding documents. , KBA , SRD-CRM-INV , Customer Invoicing , How To
SAP Knowledge Base Article - Public