Symptom
Onboarding 2.0 E-Verify Task Error, "Request Type cannot be null in requestPayload".
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Onboarding 2.0
Reproducing the Issue
- Login to SuccessFactors and go to ONB 2.0
- Take candidate's activity
- select "Accept & Confirm New Hire's response"
- Receiving an error that reads "Request Type cannot be null in requestPayload".
Cause
Customer has outdated BPE process.
Resolution
Recommended to update Process Flows for Onboarding and Offboarding to prevent the issue for any new candidates and provided workaround for impacted candidate.
- Firstly, customer must run Update Process Flows for Onboarding and Offboarding from an admin centre this is to prevent, so no new issues to come with new candidates.
- Work around for impacted candidates: we need to add a link on fanDocumentId to their E-Verify data;
Here are steps to add a link on fanDocumentId to their E-Verify data.
- Find a signed document in manage documents for affected candidate, example screenshot below
- Get Attachment ID there.
- Go to manage data -> E-Verify data -> search for E-Verify data of impacted candidate> click on correction.
- Under FAN attachment ID > put the Attachment ID which got from manage documents.
- Now go to "Complete E-Verify: Tentative Nonconfirmation:” step and refresh the page -> it should have FAN signed document now at the manager's view. Like below image.
- After page refresh, it should work fine and unblock E-Verify flow and customer can proceed further.
See Also
Keywords
Request Type, cannot be null in requestPayload, E-Verify Task Error, TNC , KBA , LOD-SF-OBX-EVF , Everify , Problem
Product
Attachments
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SAP Knowledge Base Article - Public