Symptom
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Event Notifications are not triggered when updating Key User Fields (KUT) in the Opportunity Business Object (BO).
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Notifications only occur for changes in standard BO nodes/fields.
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Customer also expects event notification for custom (KUT) fields.
Environment
SAP Cloud for Customer
Reproducing the Issue
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Log into the C4C system.
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Navigate to Administrator → General Settings → Event Notification.
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Create a new Event Notification for the Opportunity Business Object.
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In the Opportunity, add or update a Key User Field (KUT).
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Check the Event Notification consumer logs.
Result:
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No Event Notification is triggered for the KUT field update.
Cause
Currently, this is the standard behavior of the Event Notification functionality. Only fields or properties that are part of the standard nodes of the Business Object are available to the Event Notification consumer.
Key User Fields (KUT) are stored in extension tables and are therefore not included in the standard BO structure.
It is not possible to change this behavior or add additional nodes (such as extension tables) to the subscriber list. This functionality is currently not supported.
Resolution
As it is a behavior of the system, raise an idea in the SAP Sales Cloud Portal requesting this functionality:
Influence Portal
The Customer Influence portal is the correct channel for requirements of changes in the system behavior.
There, other customers can also vote for the idea and depending on the demand from the customer community, the developers will evaluate and plan accordingly for a possible implementation of this new feature.
Keywords
C4C; Event Notification; Business Object (BO); Standard Node; KUT Fields; Key User Fields; Updated vs Field Changed; Opportunity Data; RDMS; Customer Communication; Development Team; Incident Escalation; Case Status; Technical Guidance; Steps to Reproduce; UI Behavior; Error Analysis; SAP Notes; Quick Guide; Notification Trigger, Cloud for customer; NGAP , KBA , LOD-CRM-CMN-EVT , C4C: Event Notifications , Problem
SAP Knowledge Base Article - Public