Symptom
When you manually add Co-Products in the component overview during production order creation, Batch Management dialog box appears with the message: "No batch numbers were entered. Assign a new number?".
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to Create Production Order app
- In the component overview of the production order, enter a batch-managed Co-Product.
- Batch Management dialog box appears with the message: "No batch numbers were entered. Assign a new number?".
Cause
This is standard system behavior.
When manually entering the batch-managed Co-Products which are not maintained in the BOM during production order creation, the system will prompt with a Batch Management dialog asking if a batch number need to be assigned. This is because in some scenarios, the batch number needs to be confirmed during production order creation.
Resolution
If there is no need to generate a batch number for the Co-product during production order creation, just click "No" to exit the dialog.
Keywords
batch management, dialog, co-product, production order, master data, routing, BOM, batch number, manually , KBA , PP-SFC-EXE-2CL , Order Execution (Public Cloud) , Problem
SAP Knowledge Base Article - Public