Symptom
When searching for a value in a field (e.g. Cost Center) on the Time Sheet UI by entering text that includes a space, the field search returns all items instead of narrowing down the results.
Also, when you enter the text in the field and hit Enter, the system returns error message "Value "X Y" does not exist".
Environment
SAP SuccessFactors Employee Central - Time Sheet
Reproducing the Issue
- Record time data
- Search for a value with text that includes a space
- All items are shown
Cause
This is the current design. The system cannot detect a 'space' entered in the field. When a space is entered, the system returns all items. This behavior also occurs with custom fields under the Employee Time Sheet Entry object.
Resolution
As a workaround, please search by using a specific value rather than a text that includes a space.
You may submit an enhancement request to have functionalities considered within future development cycles – you can do this on our Customer Community Portal at http://community.successfactors.com/ and on our Customer Influence Portal at https://influence.sap.com/successfactors.
Keywords
search with multiple words, custom field search, Value does not exist, , KBA , LOD-SF-EC-TMS-UI , UI - Errors, Trace, RBP, Permissions, Status , LOD-SF-TTR-TMS , Time Sheet , LOD-SF-EC-TMS , Time Sheet , Problem
SAP Knowledge Base Article - Public