Symptom
- After triggering a Position to Job Information Sync, it is noticed that fields are showing incorrect values
- These field values do not match the correct value that should have been passed from the position
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Open a Position in Manage Positions
- Updated a related field and save the position
- Check Job Information of the incumbent
- Notice field value is not updated as per position field
Cause
- Position to Job information Sync saves a record in Job Information once triggered.
- This save of Job Information also triggers onSave Job Information rules.
- An onSave Job Information rule can overwrite the field value after the Position to Job Information Sync.
Resolution
- Go to Manage Data
- Create New > Rule Trace
- Ensure Login User is the same user performing the Position to Job Sync
- Ensure Rules to be Logged is 'No Selection'
- Make a save to a position in Manage Positions
- Verify Job Information record of incumbent is created/updated
- Navigate back to rule trace in Manage Data
- Refresh the page and download the trace
- Open the trace and filter the 'Action' column on 'Set' operation
- Ctrl + A to select all rows and Ctrl + F to search
- Search for the affected field identifier (e.g custom_string8)
- Review any additional rules found
See Also
Keywords
Position synchronization issue, incorrect field values, SAP SuccessFactors, Job Information update, Position to Job Information sync, field overwrite, onSave rule conflict, Employee Central, troubleshooting sync issues, rule trace analysis, field identifier search, incumbent record update, synchronization troubleshooting, field mismatch , KBA , LOD-SF-EC-POS-PTJ , Position to Job Information Sync , Problem
Product
SAP SuccessFactors Employee Central all versions
SAP Knowledge Base Article - Public