Symptom
After using the Check Tool, the Platform card is removed, and the To-Do count is reduced. However, when clicking on the To-Do tile, the task still appears.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
-
Trigger new hire tasks such as the Welcome Message.
-
Use the Check Tool to remove tasks.
-
This removes both the To-Do entry and the Platform card.
-
-
After removal, you can see that:
-
The Platform card disappears.
-
The To-Do count (New Recruit Tasks) is reduced.
-
-
However, when you click on the To-Do tile, the removed task still appears even though it was cleared through the Check Tool.
Cause
- It removes the corresponding entries from both the task list and the associated cards.
- However, when you click on Complete New Recruit Tasks in the Shellbar, the system does not check the updated task list. Instead, it looks directly at the activities that are still marked as not started or open.
- Since the welcome message tasks for the impacted users were still in one of these statuses, they continued to appear in the pop-up.
Resolution
To resolve this, the activity statuses need to be updated to Cancelled from Manage Data for the respective objects.
See Also
Keywords
Onboarding, Stale, Entries, To-Do, Check tool , KBA , LOD-SF-OBX-GDP , Data Protection , Problem
SAP Knowledge Base Article - Public