Symptom
The error message "Operation: date XX/XX/XX: operation number not unique"(Message no. CP525) is displayed when performing consistency checks for routing using "Display Routing"(CA03) application.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to application Display Routing.
- Enter the routing number.
- Click on Execute.
- Go to Operations tab.
- Click on Check
- Observe Error :"Operation: date XX/XX/XX: operation number not unique"(Message no. CP525).
Cause
The issue is caused due to duplicate operation numbers in the routing of material. The inconsistency prevents the planned order from being converted to a production order.
Resolution
- Open the routing for the affected materials in the application Display Routing.
- Navigate to the operations tab.
- Identify and correct duplicate operation numbers.
- Perform a consistency check to ensure no errors remain in the routing.
- Save the corrected routing.
- Retry to convert the planned order to production order.
See Also
Keywords
errors during plan explosion, transaction terminated, planned order conversion, production order, routing inconsistency, duplicate operation number, CA03, MD04, Manage Planned Orders, SAP S/4HANA Cloud Public Edition, Message no. CP525, error C2336, operation number not unique. , KBA , PP-BD-RTG-2CL , Routing (Public Cloud) , PP-BD-RTG , Routing , Problem
SAP Knowledge Base Article - Public