Symptom
After deactivating email notifications for a user via "Change User Email Notification", the setting auto re-enables itself.
Environment
SAP SuccessFactors HCM Core
Reproducing the Issue
- Search "Change User Email Notification".
- Enter the First Name, Last Name, Username and/or Job Code for the user you wish to alter the Email Notification for.
- Click Search Users.
- Remove the check mark in the Email Notification column check box to disable Email Notifications.
- Click Save.
- The flag will be auto enabled again after some time.
Cause
Customers may have an integration set up that calls an API, which includes the detail “purgeType=record” to update some users.
In the API, “purgeType=record” means that: your upsert request will erase all field values of the entry and replace them with new values in the request payload. More information on this can be found in help guide - Upserting Users with Parameter purgeType.
Resolution
Remove “purgeType=record” from the API call, which will stop the setting changing back.
See Also
Keywords
Change User Email Notification, notification, change, disable notification, enable, purgeType=record. , KBA , LOD-SF-PLT-NOT , Email Notifications , Problem
SAP Knowledge Base Article - Public