SAP Knowledge Base Article - Public

3656552 - Simple Product Administration API updating incorrect product

Symptom

  • When using the Simple Product Administration API, CPQ is trying to update incorrect product.
  • PartNumber is being used as identifier.

Environment

SAP CPQ

Reproducing the Issue

  1. Use the Simple Product Administration API to update a product.
  2. Provide a payload that includes PartNumber as the identifier.
  3. Attempt to update a simple product with the same PartNumber as a configurable product.
  4. Observe that the API attempts to update both products, resulting in errors.

Cause

The issue arises from using PartNumber as the identifier in the payload. CPQ uses the first product found with the same PartNumber, which may include both simple and configurable products.

Resolution

To avoid issues of improperly updating a product that has the same PartNumber, it is suggested to use productSystemId as the identifier

See Also

PRODUCT ADMINISTRATION WEB METHOD

Keywords

Simple Product Administration, API, PartNumber, Unique Identifier, ProductSystemId, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To

Product

SAP CPQ all versions