Symptom
- SF Mobile application resets every time after the authentication process is completed.
The issue occurs when navigating away from the SF Mobile app during Multi-Factor Authentication (MFA). - The SF Mobile app redirects to the login page instead of proceeding with the authentication session.
Environment
SAP SuccessFactors Mobile
SAP SuccessFactors HCM
Reproducing the Issue
- Open the SF Mobile application.
- Input the required credentials for authentication.
- Navigate to the authenticator application or method to validate MFA without closing the SF Mobile application.
- Return to the SF Mobile application, which redirects to the login page instead of maintaining/proceeding the session.
Cause
Outdated SF Mobile application version
Resolution
- Update the SF Mobile application to the latest version.
- Test the login process using the updated version to confirm if the issue persists.
- If the issue is resolved, no further action is required.
Note--
MFA Issues are not reproducible from our end, so;
If the issue persists, kindly log a case to Support Team with the following information:
- Capture the whole process of the log in via screen recording
- Confirm if the Two-Factor Authentication has ever worked or is this the first time using it
- Is this happening to both Android and IOS? If from just one of those, have you tested the same on the other?
- Version of the SF Mobile App
- Make and Module, and Operating System version this behavior is happening
Keywords
sf mobile app, authentication reset, MFA issue, login page redirection, SSO errors, mobile application update, session maintenance, authentication process, MFA validation, mobile app troubleshooting , KBA , LOD-SF-PLT-MOB , Mobile Issues , How To
Product
SAP SuccessFactors Platform all versions
SAP Knowledge Base Article - Public