Symptom
- Error while extracting data.
- Timeout error: "XXXXX:443! Timeout..."
Environment
data model / etl for sap process intelligence
Reproducing the Issue
- Open Data Modeling.
- Process Data Pipeline.
- Choose S/4HANA PRD.
- Select Business Objects: Accounts Receivable Document.
- Run ETL.
Cause
- The issue may be caused by complex operations like JOINS in the CDS View, which can increase execution time and exceed timeout settings in the network path.
- Another possible cause is that the response (data) being sent back to Signavio might be too large for the source system to handle.
- The particular CDS View may require users to possess specific authorisation roles/rights that the other tables may not.
Resolution
- Verify execution time: Run the CDS view directly in the S/4HANA system and monitor its execution time. Ensure it does not exceed the timeout settings configured for gateways or connectors. Adjust timeout settings if necessary.
- Data granularity: If the response data size is substantial, implement more granular partitioning for the table/view in the Source Data section to reduce system load.
- Authorization and access rights: Ensure all users have the necessary roles and permissions to access the CDS View I_GLACCOUNTLINEITEMRAWDATA.
Keywords
etl, cds view, i_glaccountlineitemrawdata, timeout error, sap process intelligence, data extraction error, data modeling, s/4hana prd, accounts receivable document, query execution failure. , KBA , BPI-SIG-PI-DM , Data model / ETL for SAP Signavio Process Intelligence , Problem
Product
SAP Signavio Process Intelligence all versions
SAP Knowledge Base Article - Public