SAP Knowledge Base Article - Public

3656869 - Ship-to Party box does not appear in Service order/contract

Symptom

The pop up asking a user to select a ship to partner in the instance where multiple ship to parties exist, does not appear during Service Order creation.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open the Manage Service Order App. 
  2. Click Create.
  3. Click Service Order.
  4. Enter the Business Partner ID in the Sold-to input field in the Service Order. 
  5. Enter the Product ID and the Quantity. 
  6. Press Enter. 
  7. A number of pop boxes at this stage should appear, one of which would asking to choose a ship to party record from the list maintained.
  8. However this does not happen.

Cause

  • During the automatic partner determination, the Ship-to partner is derived in access sequence step CRM_PARTNER_C (Business Partner Relationship). Since the determined value is only one (and it is identical to the Sold-to), popup is not required.

  • If there is an expectancy that the determination should come from CRM_KNVP (Sales Area Dependent Partner). In that case, multiple partners would be found and a popup list would appear. However, determination from CRM_KNVP does not occur because the sales organization is not yet defined at the time of determination 

Resolution

  • To address this, ensure that the correct access sequence is being used.

  • This adjustment allows the system waits until the sales organization is defined, after which the CRM_KNVP (Sales Area Dependent Partner) step will be triggered and the popup with available Ship-to partners will appear.

Keywords

pop up, ship to, access sequence, service order, service, contract, s/4hana cloud  , KBA , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition 2508