Symptom
Onboarding documents did not generate for some candidate.
Environment
SAP SuccessFactors Onboarding.
Reproducing the Issue
- Login to BizX.
- Complete the process as the candidate.
- After the Personal Data Collection steps, the signature step doesn't generate.
- There is an error in BPE: Monitor Process.
Cause
The issue occurred because the system was unable to establish a connection with the cloud storage service.
Resolution
Engineering have fixed the issue, for affected candidates please follow the below steps.
- Navigate to BizX.
- Update Process Flow for Onboarding > Click Update.
- Navigate to OData API Metadata Refresh and Export > Click Refresh.
- In BPE Monitor Process filter by OnboardingProcessId=enter the process ID here.
- Find the unfinished document flow block
- Copy the process instance ID of that event.
- Duplicate the tab > expand the search to 150 per page.
- Hold crtl + f and paste the process instance ID of the failed event.
- Once you find you event click on the unfinished event above that "documents.Onboarding2DocumentProcessWorkflow".
- That's the event with the error "Error, for more details check logs for ID [609cd465-c4a0-467d-881c-7e8385a9730b]."
- You want to copy the job id of that event under Jobs.
- Navigate to BPE Manage Process Tasks.
- Filter using the job id.
- Click on the result and click Restart Task.
- The signature step should appear for the candidate.
See Also
Keywords
BlobStorageError, Documents, failed, Internal Server Error, 500, OBX, BPE, error , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , Problem
Product
SAP SuccessFactors Onboarding 2505
SAP Knowledge Base Article - Public