SAP Knowledge Base Article - Public

3658023 - Signature Step Not Triggering for Candidates - Onboarding

Symptom

Onboarding documents did not generate for some candidate. 

Environment

SAP SuccessFactors Onboarding.

Reproducing the Issue

  1. Login to BizX.
  2. Complete the process as the candidate.
  3. After the Personal Data Collection steps, the signature step doesn't generate.
  4. There is an error in BPE: Monitor Process.

Cause

The issue occurred because the system was unable to establish a connection with the cloud storage service.

Resolution

Engineering have fixed the issue, for affected candidates please follow the below steps.

  1. Navigate to BizX.
  2. Update Process Flow for Onboarding > Click Update.
  3. Navigate to OData API Metadata Refresh and Export > Click Refresh.
  4. In BPE Monitor Process filter by OnboardingProcessId=enter the process ID here.
  5. Find the unfinished document flow block
  6. Copy the process instance ID of that event.
  7. Duplicate the tab > expand the search to 150 per page.
  8. Hold crtl + f and paste the process instance ID of the failed event.
  9. Once you find you event click on the unfinished event above that "documents.Onboarding2DocumentProcessWorkflow".
  10. That's the event with the error "Error, for more details check logs for ID [609cd465-c4a0-467d-881c-7e8385a9730b]."
  11. You want to copy the job id of that event under Jobs.
  12. Navigate to BPE Manage Process Tasks.
  13. Filter using the job id.
  14. Click on the result and click Restart Task.
  15. The signature step should appear for the candidate.

See Also

2246273 - SuccessFactors Outages|Disconnections, Intermittent Application Errors, Temporarily Unavailability and System|Datacenter Down - SAP for Me

Keywords

BlobStorageError, Documents, failed, Internal Server Error, 500, OBX, BPE, error , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , Problem

Product

SAP SuccessFactors Onboarding 2505