SAP Knowledge Base Article - Public

3658300 - Dynamic Property Creation: Mandatory "Case Type" Field

Symptom

During the creation of a Dynamic Property for the Case service, you realized that the "Case Type" field is mandatory.

Environment

SAP Service Cloud Version 2

Reproducing the Issue

  1. Click on the User Icon.
  2. Go to Settings > All Settings.
  3. Go to Extensibility Administration.
  4. Select Case > Case.
  5. Go to the Dynamic Properties tab.
  6. Click on the "+" (create) button.
  7. Notice that the "Case Type" field is mandatory.

 

Cause

The "Case Type" field is mandatory during the creation of Dynamic Properties for the Case service because these properties are applied based on the metadataTag, which is the Case Type. The Case entity is unique within the system, beginning with a base version, and customers can create multiple versions to accommodate various case types. Each case type can have distinct configurations for entity attributes, sections, tabs, and other aspects. This customization enables the system to adapt to the specific needs and processes associated with different case types.

Resolution

It is advised to create Dynamic Properties per Case Type to ensure they are appropriately considered and applied during process execution based on their respective metadataTags.

See Also

Create Dynamic Property Rules

Keywords

Dynamic Properties, Case Type, Case Service, Mandatory Field, Customization, MetadataTag, Configuration, Entity Attributes, Sections, Tabs, Process Execution
, KBA , CEC-CRM-CZM-EXT , Extensibility for SAP Sales/Service Cloud , CEC-CRM-CAS , Case Management for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions ; SAP Service Cloud Version 2 all versions