Symptom
- Duration field is not displayed when requesting leave through MS Teams integration with SAP SuccessFactors.
- Instead of the duration, the message "Duration not Available" is shown.
- The issue does not occur when requesting leave through browser UI or mobile application.
Environment
- SuccessFactors Employee Central Time Off
- MS Teams integration with SuccessFactors
Reproducing the Issue
- Log in to MS Teams.
- Navigate to the integrated SAP SuccessFactors application.
- Attempt to create an absence request for a user.
- Observe that the "Requesting" field displays "Duration not Available".
- Repeat the same steps using browser UI or mobile application and observe that the duration field displays correctly.
Cause
- The API returns an error message during the MS Teams integration, which prevents the requesting data from being displayed.
Resolution
- Engineering team has identified the root cause and plans to implement a fix.
- The fix involves using a lenient mode in the API, which will allow both the error message and the requesting data to be returned.
- The resolution is scheduled for release in the 2H2025 update:
- Preview environment: October 13, 2025.
- Production environment: November 14, 2025.
See Also
WRK-3582
Keywords
ms teams, sap successfactors, duration not available, absence request, api error, integration issue, requesting field, time off, lenient mode, 2h2025 release, preview environment, production environment. , KBA , LOD-SF-EC-TIM-UI , Team Absence Calender/ Workbench/ ESS UI's , Problem
Product
SAP SuccessFactors Employee Central all versions
SAP Knowledge Base Article - Public