Symptom
You are replicating Business Partner data from S4H to Sales Cloud Version 2 and the incoming message raises the following error:
"message": "{\"error\":{\"message\":\"Enter data for preferred method of contact (Email).\",\"code\":\"sap.crm.md.service.addressService.addressMessage.preferredCommunicationMediumType\",\"target\":\"{addresses/01995a5a-98c4-722d-bb45-f3b20fdbecfb/preferredCommunicationMediumType}\"}}"
Environment
Sales and Service Cloud Version 2
Reproducing the Issue
- Go to Settings
- Go to Message Monitoring
- Open the corresponding message and check the payload
Cause
You might observe the preferred channel is set as email: "preferredCommunicationMediumType": "INT"
However, the email is empty for the address or one of the addresses listed; e.g. "uri": ""
As a result, the validation logic process rejects the save operation.
Resolution
Ensure you have maintained the email information for all the addresses included in the payload, in case the preferred communication is set as INT (email).
The metadata for the address would look like the following:
- communicationPreference
- postalAddress
- facsimile
- web
- telephone
The email note is mandatory in this use case, as the communication preference channel is set as INT.
Keywords
email;communicationPreference;preferredCommunicationMediumType;cns;addressService , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Known Error
SAP Knowledge Base Article - Public