Symptom
Status triggered email sent when candidate updates application. This happens every time the candidate makes some changes in the Application with CX apply enabled and clicks on Update or Save button on the application page.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Login to the instance and make sure Reimagined candidate experience is enabled under Manage recruiting settings.
- Move the candidate's application to a status which has status triggered mail associated to. This results in status triggered mail being sent.
- Go to External career site and login as the candidate.
- Make some changes in the job application and click on update or save button in the application.
- Notice another status triggered mail being sent.
- This happens every time the candidate makes some changes in the Application and clicks on Update or Save button on the application page.
Cause
Based on analysis, this is a bug and a gap present in CX apply flow. The fix has been created and will be available coming 2H2025 Release.
Resolution
The fix has been created and will be released in the 2H 2025 release on the following dates:
- 13th October 2025 (Preview)
- 14th November 2025 (Production)
Keywords
RCM-154049, Update, Reimagined candidate experience, status triggered email, duplicate , KBA , LOD-SF-RCM-EML , Recruiting Emails and Notifications , Problem
SAP Knowledge Base Article - Public