Symptom
After saving a custom Data Product, can not add new artifacts to the Data Product. Specifically, the button to add a new artifact is disabled.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP Datasphere
Reproducing the Issue
- Log on to the SAP Datasphere.
- Navigate to the Data Sharing Cockpit.
- Go to "My Data Products".
- Open the details of an existed Data Product.
- Click on the "Edit Data Product" button.
- Observe that the button to add a new artifact is disabled.
Cause
This behavior is due to a technical limitation in the Data Sharing Cockpit. Once a custom Data Product is saved, it is not possible to remove, replace, or add views or artifacts.
Resolution
Refer to the SAP Help Portal documentation for details on this limitation:
The resolution method is:
- Create a new custom Data Product if additional artifacts need to be added.
- Ensure that the correct views and artifacts are selected before saving the custom Data Product to avoid this limitation.
Keywords
Data product, Add artifact, Data sharing cockpit, Sap Datasphere , KBA , DS-DM , SAP Datasphere Data Marketplace , Problem
SAP Knowledge Base Article - Public