SAP Knowledge Base Article - Public

3659439 - Unable to add new artifacts to a custom data product in Datasphere

Symptom

After saving a custom Data Product, can not add new artifacts to the Data Product. Specifically, the button to add a new artifact is disabled.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP Datasphere

Reproducing the Issue

  1. Log on to the SAP Datasphere.
  2. Navigate to the Data Sharing Cockpit.
  3. Go to "My Data Products".
  4. Open the details of an existed Data Product.
  5. Click on the "Edit Data Product" button.
  6. Observe that the button to add a new artifact is disabled.

Cause

This behavior is due to a technical limitation in the Data Sharing Cockpit. Once a custom Data Product is saved, it is not possible to remove, replace, or add views or artifacts.

Resolution

Refer to the SAP Help Portal documentation for details on this limitation:

https://help.sap.com/docs/SAP_DATASPHERE/e4059f908d16406492956e5dbcf142dc/bbcbf42b0cb541529e63628d95f394c8.html

The resolution method is:

  1. Create a new custom Data Product if additional artifacts need to be added.
  2. Ensure that the correct views and artifacts are selected before saving the custom Data Product to avoid this limitation.

Keywords

Data product, Add artifact, Data sharing cockpit, Sap Datasphere , KBA , DS-DM , SAP Datasphere Data Marketplace , Problem

Product

SAP Datasphere all versions