SAP Knowledge Base Article - Public

3660040 - Utilities Customer Search is not consistently searching across all customer types in C4C

Symptom

When searching by name, the system often returns only Individual Customers and omits Accounts when both share common or similar names. Searches for uniquely named accounts work correctly.

Environment

  • SAP Cloud for Customer
  • SAP Cloud for Customer Integration with S/4HANA Utilities

Reproducing the Issue

  1. Log in C4C.
  2. Navigate to Utilities Customer Search.
  3. Enter a common name shared by both Individual Customers and Accounts (e.g., "Smith").
  4. Observe that mostly or only Individual Customers are returned.
  5. Search for a unique account name — the account is displayed correctly.

Cause

For performance optimization, the search currently fetches only 100 records. As a result, not all records are displayed.

 

Resolution

If you requires all records to be displayed, implement the BAdI COD_UTILITIES_ERP_CUST_BADI method ACCOUNT_SEARCH_PRE, where the maximum count value can be increased as per requirement.

Keywords

Customer search, Account, Individual Customer, Utilities, C4C, Cloud for Customer, BAdI COD_UTILITIES_ERP_CUST_BADI, method ACCOUNT_SEARCH_PRE, searching, finding, filter, filtering, Account, Customer, name, description. , KBA , LOD-CRM-IND-UTL , Utilities , How To

Product

SAP Cloud for Customer core applications all versions