Symptom
When an email is sent via an Autoflow Rule, you notice that the attachments added directly to the email template used are not sent along in the email to the recipient.
Environment
SAP Service Cloud Version 2.
Reproducing the Issue
- Logon to the SAP Service Cloud Version 2.
- Click on the User Profile.
- Click Settings.
- Navigate to All Settings.
- Click Templates under Emails.
- Select any email template.
- Navigate to Attachments tab.
- See this template has attachments maintained.
- Navigate to Emails work list.
- See the outbound emails.
- Navigate to Attachments tab.
- See no attachments were sent, even though the email template was applied to the email sent via the Autoflow.
Cause
Sending email template attachments in outbound emails sent via the Autoflow rules is not a supported functionality as of now.
Resolution
At the moment, email template attachments will only be sent via the emails manually created in the email composer / feeder.
Keywords
Emails, Email Feeder, Email Compose, V2, Version 2, SAP Service Cloud Version 2, Email Template, Templates, Template Attachments, Email Template Attachments, Attachments, Autoflow, Autoflow Rule, Rule, Outbound Email, , KBA , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , CEC-CRM-AFL , Autoflow for SAP Sales/Service Cloud , CEC-CRM-DOS , Document Service for SAP Sales/Service Cloud , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , How To
SAP Knowledge Base Article - Public