SAP Knowledge Base Article - Public

3660398 - Attachments Added to Email Templates Not Sent via Email Triggered by an Autoflow Rule

Symptom

When an email is sent via an Autoflow Rule, you notice that the attachments added directly to the email template used are not sent along in the email to the recipient.

Environment

SAP Service Cloud Version 2.

Reproducing the Issue

  1. Logon to the SAP Service Cloud Version 2.
  2. Click on the User Profile.
  3. Click Settings.
  4. Navigate to All Settings.
  5. Click Templates under Emails.
  6. Select any email template.
  7. Navigate to Attachments tab.
  8. See this template has attachments maintained.
  9. Navigate to Emails work list.
  10. See the outbound emails.
  11. Navigate to Attachments tab.
  12. See no attachments were sent, even though the email template was applied to the email sent via the Autoflow.

Cause

Sending email template attachments in outbound emails sent via the Autoflow rules is not a supported functionality as of now.

Resolution

At the moment, email template attachments will only be sent via the emails manually created in the email composer / feeder.

Keywords

Emails, Email Feeder, Email Compose, V2, Version 2, SAP Service Cloud Version 2, Email Template, Templates, Template Attachments, Email Template Attachments, Attachments, Autoflow, Autoflow Rule, Rule, Outbound Email, , KBA , CEC-CRM-EML , Emails for SAP Sales/Service Cloud , CEC-CRM-AFL , Autoflow for SAP Sales/Service Cloud , CEC-CRM-DOS , Document Service for SAP Sales/Service Cloud , CEC-CRM-TMP , Templates for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 all versions ; SAP Service Cloud Version 2 all versions